Red > Green > Refactor > Red

cycle is based on desire

NoeBundle neocomplete で if lua エラーが起きた記録

考えられる原因

1. Vim のバージョンが 7.38 未満

かつ

2. Vim の configure (言い回しに疑問有り) に

  --enable-luainterpre

が設定されていなかった。

 

対策

1-0. 現vimをアンスト。

1-1. Vim をソースからインスト。

1-1-1. hg clone https://vim.googlecode.com/hg/ vim

vimのソース取ってくる。

1-1-2. vim/src に cd して configure で --enable-luainterpre を指定

1-1-3. そもそもの lualua ライブラリ群をインストしておくこと。